Download Software

Windows 8 / 7 / Vista / XP

Gigajam Xtractor X5 requires Microsoft .NET Framework 3.5 SP1, which may already be installed on your system. You must ensure that you install this before installing Xtractor. Even if you think you may already have .NET installed it's still worth running Microsofts installer to check so, there may be recent updates.

Install GigajamXtractor X5 by downloading to your hard disc drive and then double-clicking the msi file. X5 now contains all Xtractors in one application, as well as Analyser.

Some assets on this site also require Adobe Reader.

After downloading checkout your first lessons

Community Technology Preview

If you'd like to see the new Xtractor, including a software synth then check out the beta.

MacOS X (v. 10.3 Tiger to 10.6 Snow Leopard)

Our Mac version of Xtractor WILL NOT work on the latest version of Mac OS X, Lion. Please email support@gigajam.com for advice and up to date details of new release schedule for MAC including iPad, iPhone and mobile devices.  

Gigajam Xtractor was designed for PowerPC Macs but will also run on Intel based Macs. The Mono Framework is now a universal binary and will install on either and run natively. Xtractor and Analyser have been tested and found to work perfectly under Rosetta.

Windows Media Player for OS X is no longer required. Instead we recommend that you use the Flip4Mac plugin for QuickTime, it works seamlessly and saves having an extra media player installed.

Some assets on this site also require Adobe Reader.

After downloading, checkout your first free lessons.

Driver Downloads

Here are some links to drivers commonly used with Gigajam